Support

 

» SYSTEM REQUIREMENTS

Is my device and browser compatible with Spark? See System Requirements Tip Sheet

For computers:

  • Operating system: Windows® 7, 10 or higher, OS X 10.15 or higher, Chrome OS 85 or higher
  • Web browsers (in the latest version): Chrome, Microsoft Edge, Safari
  • Processor: Intel Core™ Duo 2.0GHz or faster processor
  • Screen resolution: minimum 1366 x 768 px
  • Memory: 2GB or higher RAM
  • Cookies: must be enabled

For tablets:

  • iPad Air and iPad Pro
  • OS 13.1 or higher

» STUDENTS

Student Help Site:

mypearsonhelp.com/helpconsole7/kb_spark_stu_en/

  • Checking Your System Requirements
  • How-To Videos
  • Platform Features & Functionality

» EDUCATORS

Teacher Overview Video

 

Teacher Help Site:

mypearsonhelp.com/helpconsole7/kb_spark_edu_en/

  • Checking Your System Requirements
  • How-To Videos
  • Platform Features & Functionality

» CONTACT